Frame speed slow

I’m new to the Pearl Nano but I’m only seeing a frame about every 15 seconds. I’ve double checked my settings and I’m using a network camera on RTSP connectivity. Current frames shows 30 but it definitely isn’t as seen through the stream live broadcast. The LCD on the front of the unit is better but still not perfect. Any help would be appreciated.


It sounds like you’re seeing a low frame rate produced by Nano but the front display is of a higher frame rate - I believe you’re comparing different pages of the Pearl WebUI to the display of the Nano, is this correct?

Please note, certain pages of the Pearl WebUI refresh video snapshots at a very low framerate (some seconds) where full frame rate is not needed, for example the input pages.

The Nano display will display a higher framerate, but this display’s purpose is for confidence monitoring and not high fidelity full frame reproduction, something you would see from a connected HDMI monitor, streams or recordings from the Nano.

Please try recording with the Nano, connecting an HDMI display, or streaming to an endpoint like YouTube to see if the same low framerate is seen

Yes, the youtube stream is also very choppy.

I see - if you perform a recording with the Pearl Nano is the same choppiness seen in the local recording as well? It is possible you’re experiencing networking issues and the encoding bitrate is overwhelming your available upstream.

We’ve got 10G internet pipe and are only utilizing about 1.5.

Thank you for that - it is possible your network has some QoS settings that is not allowing full utilization.

The best way for me to understand what you’re seeing is to compare the stream bahaviour to the recordings. Both are from the same pipeline, so if the recordings are smooth but the stream is not, that may likely indicate networking issues.

Please feel free to submit a support ticket at sharing a recording with us and an example of stream performed by Nano.

It’s an IP camera and when I view just the camera in a browser it looks fine.

All is working well now, thanks for your assistance.

Pixelating at bottom of screen.

Hello - the above issue looks like packet loss, meaning somewhere in the transmission data packets are lost/dropped so this washing/smearing of the video is seen. This could be caused by a number of things like QoS (quality of service) settings on your network, network instability, or a network bottle neck somewhere in your environment.

I’m not exactly sure what this screenshot is of - can you please elaborate on what you’re taking a picture of and where the content is coming from?

Is this the RTSP feed from the camera you mentioned in the ticket you submitted via

Have you tried streaming the RTSP camera to VLC or something else on the same network as the Nano to see if the same issues are seen?

Please note, we’d be happy to troubleshoot in either forum, but tickets can typically result in quicker and more in-depth responses

Sorry, I thought I replied to the ticket that I opened last week. I’ll locate that and reply there.

1 Like

General update - the issues reported and seen above were caused by an external physical network switch that was causing packet loss; not all video data from the networked camera was arriving at the Pearl input.