YouTube cant start streaming

Hi,i’ve still cant stream on youtube. Pairing is ok but soon as i clik start, popup windows bring me to the saurce of the divice app as show on these 2 pictures. A help.



I believe this is a likely a YouTube account issue. I have seen this before where the Webcaster X2 receives an unexpected error from the YouTube server relating to the account in question not having proper streaming permissions and then the Webcaster X2 crashes. This has been reported to the development team for them to resolve the crash and instead show an error message. However to actually use this account for streaming you will need to contact YouTube support for them to fix the account issue. You can confirm this by testing with another YouTube account.

Mine does the same thing. If i stream from my phone it has no problem.
Facebook works fine. Just youtube.

Hi Tessa. If you are seeing the same thing then the same recommendation would apply: you will need to contact YouTube support for them to fix the account issue.

If it streams from my phone to youtube then why would it be there problem?

Webcaster X2 uses a different method of pushing the stream to YouTube than the app does.

Have you enabled the Live Streaming functionality through your creator dashboard? We just tested a Webcaster here to make sure it works and it does work with all of our channels.

I am having the exact same problem. I can live stream to my church’s YouTube channel with my iPhone, with my webcam on my laptop, but not with the Wecaster X2. It does, occasionally, connect. When I tested my setup last week it worked flawlessly for almost an hour before I stopped the live stream. Yesterday morning it crashed on the first attempt to start the live stream. This morning I came in and it connected without issue; until I stopped my live stream and tried to restart it. While I understand that the Webcaster X2 uses a different method of pushing the stream than my iPhone or laptop, if it were a permissions issue that would be exclusive of the method, wouldn’t it? Additionally, since it does connect “sometimes” that doesn’t sound like a channel permission issue. Something is wrong with the firmware and a bug is causing the crashes, at least, that seems far more likely…

@Senior_Pastor I think I may have been emailing you earlier regarding this?

To elaborate, there is a known issue where the Webcaster will crash as you describe if you click Start for streaming to YouTube and then YouTube sends an unexpected response instead of creating the new live stream. In any cases like this that has come up the YouTube support team has been able to rectify this, though I do not know what the root cause is. In some cases this may be related to potential copyright or guidelines violations. For some reason this issue seems to only affect the API and other stream types still seem to work.

You can get a quick overview of the state of your YouTube account here:

I would recommend filing a ticket with the YouTube support team though, as they should be able to rectify this:

Well, for some reason the Webcaster decided to start working this morning. After several failed attempts to start the live stream, I was able to start/stop our live stream about 4-5 times, without issue. I have been in contact with Epiphan’s tech support team, and have sent an email in with the S/N and MAC Address of my device, and they will assign a developer to look at the performance logs and see if there is any other issue that needs attention.

Thanks for your response!

I thought i had this thing working then it started doing it again. I haven’t used it for a few months. It quit in November and I just tried it again same problem.

Hi Ken,

Did you end up filing a ticket with YouTube support? If so, what can you tell me what they said?

We just ran into this same issue this morning. Everything was fine three days ago, but this morning, we get the same crash as described above.
I tried to follow the instructions to file a ticket with YouTube, but our channel is small enough that there is no email support or ticket filing mechanism that I have been able to locate. All we have access to is the community forum, it seems.
Is there any other way to fix or work around this issue, or has our webcaster box just become useless?

It does seem that you will need to be part of the YouTube partner program in order to file a ticket unfortunately. Sorry to say but as this is a YouTube account issue it isn’t something we at Epiphan can fix. Other than contacting YouTube (either directly or via their community forums) the only things I can suggest is to use a different YouTube account, or stream on a different platform such as Facebook or Twitch.

I just started getting this same problem after successfully streaming events for over a year to youTube live using the X2. I can go all the way to log in then get the Epiphan logo and get bumped back to the enter code screen.

I tried reseting the x2 to factory defaults which didn’t work. I can’t find any settings with YouTube that would help. Apparently there’s no solution so I’m just posting for awareness of this seemingly expanding issue.

UPDATE 5 minutes later. It’s working now after making no changes that I’m aware of.

This just happened to me last week, I have been live streaming events for several months now with this device. Has there been any new developments on this issue? Facebook live is working as normal, YouTube live crashes as soon as I hit Start. I have reset and updated the device already with no luck. Any advice will be helpful, thank you.

I just received the Webcaster x2 today. Same problem. This is disappointing. Our nonprofit really wanted to use this.

Same here
tried 3 different youtube accounts, all of which work streaming from a webcam.
We are not a YouTube partner (nor are likely ever to be) so we cannot access their support on this.

X2 is advertised as working with youtube, but their product is not fit for purpose.

It is really not good enough to say - oh it is a youtube problem, when the product basically just crashes if something is not as it expects. There should be at least some contact between yourselves and youtube to tell your customers what to do next.

We are actively trying to find a workaround for this! At the moment the only thing I can suggest is to create a YouTube Live event and stream to this instead of using Stream Now. You can find details on using this here:

I think this issue need to be addressed and software update pushed… As contacting youtube wasn’t helpful at all as the said I have to work with another encoder or OBS instead

This has been reported to YouTube, it is something they will have to fix on their end. Unfortunately it isn’t something we can solve on our side. The workaround would be to go here: then click Reveal and Reset. This should fix it!