Webcaster not letting me use switchboard

When I try to use switchboard the box says stopped streaming but I can use anything else on the box fine

Can anyone tell me how to fix this so I can use switchboard

Hello Johnny,

Can you please attempt to pair your WCx2 and use Switchboard once again? We believe this integration should now be working as expected.

Talk soon,

1 Like

Hola, uso mi webcaster x2 con switchboard, hoy no me enviaba la señal de vídeo y elimine el workflow para volver a enlazarlo y no me permitió enlazarlo nunca, podía enlazar en YouTube, Facebook directo pero no en switchboard. Que puedo hacer? Nunca tuve problema para enlazarlo antes

hmmm - While the Webcaster X2 was deprecated over three years ago, I believe it should still work with Switchboard Live, unless something changed on Switchboard Live’s end. Have you tried reaching out to SwitchBoard Live to see if they may have any information?

I have gotten that issue resolved between the webcaster not pairing with switchboard

Good news - could you please let me know what the issue was?

It was something switchboard messed up when they did an update to there page but they fixed it

1 Like

Hi! Well the pairing problem was solve but today I didn’t get signal (it was pair) I try to remove the workflow and and the destinations to livestream, I allow the permits to each page and… send me an error I was enable to livestream again… so I want to know if I need to change my encoder or it’s a problem with switchboard?


We are not aware of an ongoing outage at this time. Could you please reach out to Switchboard to inquire about the error?