Sdi2usb 3.0 not working in ubuntu 18.02 as secondary video source /dev/video1

I am trying to use epiphan SDI2USB with ubuntu 18.04. I downloaded the correct driver from their support site and the driver is correctly installed. My kernel version is 4.15.0.

If I try to run vlc and i go to media menu → Open Capture Device → video device name → Here I see both my /dev/video0 (integrated camera) and /dev/video1 (epiphan video) When I select /dev/video1 and click play, I can see it works fine.

However when I write a simple python program from internet and run it, I get an error

compass-admin@Alienware-13-R3:~$ sudo python3
Insufficient buffer memory on /dev/video1 – decreasing buffers
Insufficient buffer memory on /dev/video1 – decreasing buffers
mmap: Invalid argument
munmap: Invalid argument
VIDEOIO ERROR: V4L: can’t open camera by index 1
munmap: Invalid argument
Traceback (most recent call last):
File “/home/compass-admin/.local/lib/python3.6/site-packages/numpy/lib/”, line 843, in split
TypeError: object of type ‘int’ has no len()

I dont know if it is because of permissions or if you have to use a specific function in opencv. No matter what I do, I get the same error.

I changed permissions of /dev/video1 to 777, I also added the current user to video group but no luck. I also tried video source in opencv as 0, 1, -1 but no luck. Any help please.