Pearl Mini streaming not working after firmware update

Hi We have Pearl mini and we updated from 4.8 to 4.15. After update, streaming parameters changes are not stored. When I click apply, everything looks ok. Start-button is greyed. If I go to other settings (it does not matter what) and come back, streaming settings are blanked.

Other settings like layouts I can add, change network settings etc. i.e. streaming seems to only one.

Sometimes this can occur due to internet browser caching. please clear your browser cache and the web UI behavior should be corrected to intended function. As a practical test, you can open an incognito mode browser, or a different web browser type entirely to test and you should have full device function!

If the issue persists, please let us know

Hi I out chrome on incognito. I attached two screens, one with filled and other one blanked after I clicked Metadata and returned to Steaming page. Stream config remains, but it empty. I can ping and resolve names correctly i.e. network is ok.

Image removed due to privacy concerns

And this empty page after. I have pressed Apply, then Delete this stream goes get and comes back available.

Please try deleting that RTMP instance from the channel and creating a new one from scratch.
If the issue persists, please try from a different browser

I would also recommend performing a factory reset to ensure that there are no low-level UI bugs introduced from jumping 12 firmware versions, and manually reconfiguring the device

Hi Tried with two browser, safari and Chrome. same results. If I add Stream, config (URL and stream name9 and click apply, Start button is grey. If I click Stop All (there is no streaming air though) and stream settings are empty again. I didi factory reset once, maybe I have to do it again? It sounds bug in latest fw.

I noticed you also sent in a support ticket so I will continue correspondence there for troubleshooting. Based on your wording, please ensure that you attempted a factory reset by going to the very bottom of the maintenance page and clicking on the factory reset option. There is a configuration preset section which shows “factory default” which refers to the configuration, however this is not a reset

Hi, Yes I Did factory reset. For example IP changed and channels changed

After careful troubleshooting, we were able to determine that there was a remote-access security measure that was preventing the settings from being applied.

Logging in via Epiphan Cloud to configure resulted in expected behavior


yes, we can configure parameters via local windows 10 laptop. we started streaming to youtube, but Pearl gave error Connection closed by remote host. I tried to look what is causing
this, but could not find?

BR. Ossi

Connection closed by remote host can occur for a few different reasons.

Most commonly, the channel’s encoding settings do not match what the CDN requests/requires. Looking at the CDN’s FAQ will usually outline its desired parameters. Youtube, as an example, is incredibly particular about the audio codec and bitrate (AAC 44.1 or 48, 128 kbps)

If the issue is not encoding settings, it can be a connection/communication issue between local network and the CDN - typically caused by Firewall or network security restrictions preventing proper communication. You can find a list of network ports used by Pearl here
Standard RTMP Push CDNs will use Ports 80 and 1935
Pearl also has network diagnostic tools available from Pearl’s touchscreen on the network page, or in the Web UI at the bottom of the network page as well. This would allow you to run connectivity tests, traceroute test, DNS, Ping and more


Streaming works ok now.

My colleague have problem with HDMI output i.e. there is no source selection? attached is screen shot.

BR. Ossi

Hello Ossi!

In most cases when we see the HDMI output page unpopulated this indicates a browser caching issue, incompatible browser, or a factory reset needs to be performed. A factory reset is usually only needed when jumping firmware versions, but we do recommend after each firmware upgrade as best practice.

Looking through the correspondence you had with Mat, I can see that initially remote security settings were causing the reported issues. Mat was able to pair your Pearl device to his Epiphan Cloud account and functionality was expected. Is your collogue accessing the Pearl device via Epiphan Cloud or a custom VPN?

Can you also please confirm you have performed a factory reset since upgrading to 4.15.0, and then cleared your browser cache, using a supported browser (Chrome, Firefox, Edge)?

Talk soon,