Pairing code for Facebook live streaming

Hi my x2 isn’t generating a pairing code. Just updated the firmware. What alternatives do I have?

Did you find a solution for this? I am having the same problem.

If the Webcaster isn’t coming up with a pairing code this is almost certainly a network / internet problem of some kind where the Webcaster cannot retrieve the code from the Facebook servers. If this is a corporate network it is most likely to be a firewall issue, in which case I would recommend speaking to your network admin and letting them know that the Webcaster will require the use of outgoing ports 80, 443, and 1935.

Been having the same issue for the past couple months, didn’t use to happen before. It has delayed livestreams with clients because it will not pair (aka doesn’t give me a code) or it will unpair last minute, making me wait until it decides to give me a new code.

I am on a personal network not on a corporate network.

I just got a new Webcaster X2 today and soon as I got it upgraded the firmware then tried to connect to facebook and it never generates the application paring code. It also flashes a red bar at the bottom of the screen behind the pairing window every few minutes that says the facebook application has been deleted. My guess is facebook deleted your apps API access do to the crackdown on 3rd party apps.

HEre is a screenshot of the error

We apologize for the inconvenience. Our development team is working closely with Facebook to try and determine the cause and resolve the issue, but we hope to have it resolved as soon as possible

We’re pleased to report that streaming to Facebook can resume. Should you need further assistance, our support team is available via live chat from during normal business hours Monday through Friday - or you can email

Thank you for your patience while we worked with Facebook to quickly resolve this issue.

I’m having this issue. Facebook wont generate a code

If you are unable to receive a code, it is typically because Webcaster X2 is unable to reach the servers to communicate with the platform. The common cause to this is a firewall preventing access over port 443. You will need to ensure that Port 443 is not blocked on your network