No Signal (no HDMI, and no USB)

Hi There,
Webcaster x2 started to show “No Signal”

Worked fine for some time, but now it keeps saying “No Signal”.
Tried multiple cameras- GH5s, A7rIV, goPro black 6…
Tried many different cables… - same screen- green sign “No Signal” over black screen.

In upper left corner of screen it shows “HDMI IN: 1920x1080” when i connect any of my cameras - so it looks like it detects the signal, - but still it shows black screen with “No Signal” sign in the middle.

When I press “Z” key on keyboard, or “ctrl+ Z” - it shows split screen- and it shows live video from camera coming fine, but when i hit z again- it goes back to a single black screen with “No Signal” sign in the middle…

When connected 2 cameras- GH5s with HDMI, and sony A7RIV with USB (A7RIV HDMI to a capture card to USB, and that USB to webcaster x2), it started with showing both cameras fine for about couple seconds, then both showed “No Signal”

Any ideas how to fix that?


Sorry to hear about this issue! Have you tried a full factory reset? To do this you would click the Settings icon at the lower right corner of the screen and select “backup and reset” under the “Personal” subheading.

After selecting backup and reset you will be asked a number of times to confirm the reset. Once the final confirmation has been received the unit should reboot.

Please note that it’s important to disconnect the HDMI input from the Webcaster prior to performing the factory reset. After the reset when the unit reboots you can reconnect the HDMI.

Hope this helps, let us know!