Help Needed: Pearl 2 SRT streaming not working

Hello Community,

we use the Pearl 2 in our streaming studio as an encoder for RTMP and SRT streams. This has worked extremely reliably so far and never caused any problems. However, recently we have not been able to establish SRT connections. No traceable changes were made to the settings and we are using the same hosting provider as usual.
We mainly use the German provider 3Q. For testing purposes, we also tried Wowza, but unfortunately no connection is possible here either.

Typical error messages: High packet loss; Frequent reconnections, Time out.

Interestingly, Wowza shows that a connection attempt has been made, but it aborts immediately.

Unfortunately, neither an software update nor a factory reset helped.

The error cannot be assigned to the network either, as a vmix system on the same network can establish successful and reliable connections.

RTMP streams are working fine.

Does anyone have similar experiences/problems or a possible solution for us?
Any support would be greatly appreciated.

thanks to all

Hello Jannic,

Hmmm, this is certainly strange behavior - in most cases where we would see an error stating something like “high packet loss, frequent reconnections” this would almost certainly be attributed to the network. It is indeed curious that the RTMP stream works fine, while SRT does not in this case. Could you please send us an email at addressing the following questions so we may dig a little deeper into this issue?

Where exactly are you seeing this error? (please provide screenshots)
What is your upload bandwidth on this network and is this network shared by any other devices?
Is the RTMP test stream being sent out at the same encoding settings/bitrate as SRT?
What is your buffer set to in your SRT settings?
Does increasing your buffer result in connection to 3Q or Wowza?

Hello Ryan,

thank you very much for the quick reply and your offered support.
Unfortunately, I am currently very involved in an ongoing project and cannot provide the needed information immediately.
I will probably get back to you by the end of this week and answer the points mentioned.


Completely understand - Until then, do take care!

Hi Ryan,

Sorry for not getting back to you.
We were able to trace the problem back to our network. To increase resilience, we use a bonding router that distributes traffic across multiple DSL lines and LTE connections and bundles it back through a data center. There must be a bug in the configuration that is not yet known. Both RTMP and SRT work perfectly on the Pearl via a simple DSL connection.

Jannic - thank you so much for getting back to us regarding this. I’m happy to hear you have determined the root of the issue so you may now move forward in finding a solution that works for you!

Please never hesitate to reach out in the future!