Get "Invalid credentials" warning when click Start button in epiphan video program (on screen)

I just got a Webcaster x2 from a friend and I plugged it in and it worked just by using the address provided! I could see the streamed video on Youtube.
Then I unpaired it and registered it using my email using the Google connect device webpage and the pairing code provided by webcaster. Now when I click Start (on screen) I get an “Invalid Credentials” message and streaming will not start. I tried unpairing and pairing two more time (with new codes) but get same result.

Is there a solution to this, or do I need to do a factory reset and start at square one?

I changed my gmail account as the one I was using must have been limited so that it did not have Youtube access. Redid the pairing with the new gmail account. Rebooted Webcaster and when it was ready, clicked Start (on screen) and got some streaming not enabled error. Went back to Youtube, created a channel and enabled streaming. Now I get a “Can’t retrieve persistent broadcast from Youtube” error and it wont connect.

Am I on the right track? Youtube said it could take up to 24 hours to enable live streaming.

If you just enabled streaming then it will indeed be 24hours before this will work on that account unfortunately.

Wow, thanks for getting back to me so quick!