DVI2USB 3.0 captures limited to 29fps

The Epiphan Capture Tool status bar shows 1920x1080 60.2Hz but will only capture 29fps with “Limit frame rate to” unticked. Compression doesn’t matter, I always get a 29fps file. Switching to a lower resolution doesn’t affect anything, the results are the same.

If I tick “Limit frame rate to” and set it to 60, different things happen depending on compression:

  • Full uncompressed just creates a 60fps video file, but it’s contents are still ~29fps (only every other frame is actually a new frame)
  • HuffYUV or Lagarith creates a 60fps video file, but the actual captured frames tanks to <1 fps

I’ve tried different USB3 ports on completely different devices (one on the motherboard, one on a PCIe card) with identical results. Both Windows 10 and Windows 7 yield identical results (I dual-boot so I can use an older SD capture device that doesn’t behave with Windows 10).

EDIT: I forgot to mention that I confirmed the source is 60fps using a different USB3 capture device.


Couple of thoughts about this;

Refresh rate (hz) and frame rate are not quite the same thing, what’s the video source being captured and how are you confirming that it’s actually running at 60fps (where each frame is unique), as opposed to 30fps encapsulated in a standard 60hz signal etc.

How are you confirming the frame rate of the recorded file? i.e. a fractional frame rate such as 29.97 might appear as 29fps in certain software but effectively it’s 30fps

Same basic question for the HuffyYUV / Lagarith video file, those formats are too heavy for real-time playback and it would appear as if the frame rate was 1fps or less. You would need to put them into an editing program or VLC and go through frame by frame to confirm (or re-encode to a real-time codec)

What happens if you set “Limit frame rate” to 30fps?

Have you tried capturing in any other programs, VLC, OBS, etc?