Can´t Retrieve persistent broadcast from youtube

Hi, dear Forum. we are a reseller and after tried several times we get this message from X2. please help to resolve this issue "Can´t Retrieve persistent broadcast from youtube "
thanks in advance.

This error can be caused by an uncommon bug on Youtube Stream Now. This has been reported to YouTube, it is something they will have to fix on their end. Unfortunately it isn’t something we can work around on our side.

Usually it seems to fix itself on YouTube’s servers by temporarily setting up an Event stream and choosing that as the destination for Webcaster. After running that as a simple test, the Stream Now error is usually cleared. It will clear with time as well, but that seems to be random. To create a Live Event on the YouTube webpage you can go here: Then click to create a new event. Then you would enter a Title, set it to Type: Custom and click Create. After you create it, select Single-use stream key. Now on the Webcaster X2 you can go under Preferences -> Publish Destination and select the Title of the event here.

Hi guys, at last I’ve found the solution to this problem , whilst streaming live to YOUTUBE on the WEBCASTER*X2 we encounter the following error message , CAN’T RETRIEVE PERSISTANT BROADCAST FROM YOUTUBE.

Go to YOUTUBE.COM and then go to right hand corner and press your profile initial.

Next press YOUTUBE STUDIO (beta) then go to left hand side and press OTHER FEATURE S, in the next box press LIVE STREAMING , when you’ve done this go down to bottom left of page and see STREAM NAME/KEY to the right of this see the word REVEAL press this and see the word RESET press this and problem solved, Save this solution for next time it happens.


1 Like

Ah so if you just go here: then click Reveal and Reset it fixes it for you? Great to hear!

1 Like

Thanks Adam for the shortcut mate.

Thanks for letting us know that this fixed the issue for you! Hopefully it works for everyone!

Click Me!

Thank you Adam, I’ve used it three times since starting with the Webcaster x2, I have two of these x2s and it worked every time mate

But must admit your shortcut cuts out all the hard work.