2.14 Update goes to Android System Recovery

We tried to update our [still new] Webcaster X2, but the update process doesn’t seem to work as stated in the update firmware section of the epiphan website.

We click “Update available” and the firmware downloads 100%. Then we click “Restart to Install”, the front display reads “Updating firmware”, and then . . . we get a nice colorful text menu with “Android system recovery” at the top.

The bottom of that screen shows some errors in yellow that read:

E:failed to mount /mnt/external_sd (No such device)

…so we chose the non-catastrophic option of rebooting which brings us back to the main Webcaster X2 control screen.

To clarify, we do NOT have an external usb drive connected to the Webcaster X2, and we’re using a regular keyboard/mouse. The first few times we tried to update, the unit was restarted by clicking “Restart to install”, and in later attempts we tried to restart by disconnecting the power. If it means anything to anyone, in Settings/About the device’s Kernel version is 3.10.0 and the Build number is “epiphan_wcx2-userdebug 5.1.1 LMY48G 2.14.90279 release-keys”.

As it stands, our Webcaster X2 seems to still be working, but we continue to get the “Update available” notification yet no matter how many times we try to update, the device just goes to that “Android recovery menu”.

Does anyone know why this is happening?


I have exactly the same problem!!! I post the photos

Hi Chris,

Can you tell me the serial number and the Mac address of this unit? Both would be found on a sticker on the bottom of the device.

Here you go:

If you can boot up the unit and leave it connected to your network then I can ask one of our developers to push the update to the unit which should resolve the issue.

Hi Adam,

Okay the Webcaster x2 is powered up and connected to our network gateway. How long will it take before this can be done?

Kind Regards,

The update is done! Our dev team manually pushed the update to the units and they believe this will resolve the problem. Can you check to see if it is all working properly?

Problem solved! :slight_smile:

Wow that was quick. Thank you. Hopefully the next time we have to update our Webcaster x2 we’ll be able to do this for ourselves.

Kind Regards,

I have the same problem.

Hi Frank, I emailed you regarding this, but I will post this here also:

If you can provide me with the units serial number and MAC address, which are written on a sticker underneath the device. If you then leave the unit powered on and connected to your network I can ask a developer to remotely push the update to the unit. This will fix the problem.

Hi. Thank you.
Just saw your mail.
Thanks for responding.
The SN: WCX217124361
MAC: 98-00-00-01-37-0C

Frank Jürgen Dück
Filadelfia, Paraguay
Tel.: +595-981 858 938
WhatsApp: +595-981 858938
Email: frankdueck19@gmail.com

I have asked our dev team to push the update to this unit, I will email you back directly to let you know once they have done this!

Hi Adam,

We seem to be having the same issue again.

The main screen of our Webcaster X2 says “Update available”, but when we click it the device acts like it’s updating firmware and then goes to that “Android system recovery” screen. After restarting, the Webcaster main screen again says that there is an “Update available”.

When we first got our Webcaster X2 updates installed without a hitch. Why are we having this issue now? :confounded:


Hello Chris,

Are you able to email us your Webcaster X2 information and the issue so that we can get a developer involved to try and resolve the issue?
You can email info@epiphan.com

Hi Mrenaud,

Sorry… I didn’t have notifications turned on for this thread. I will email info@epiphan.com for further assistance on this rather perplexing issue.

Thank you.


Mine simply says Firmware failed to update.

I highly recommend that you contact Epiphan Support on this.

Here is what is supposed to happen:

  1. You click “Update is available” and the firmware file downloads,
  2. You click “Restart to update” and the unit restarts,
  3. The monitor screen then displays a rotating letter “e” (looks like the Epiphan logo) indicating that the device’s firmware is currently in the process of being updated.

If you don’t see #3 happening then your Webcaster X2 isn’t updating.

We were experiencing a problem in which our unit, instead of showing the rotating letter “e”, kept booting to an Android Recovery screen. We contacted support and even after their Dev Team remotely connected and manually updated it, we kept getting “Update is available” notifications (clearly indicating that unit wasn’t updated). We sent the unit in for repair, and they sent us a replacement. Now when we update the device it restarts to a proper update screen showing a spinning letter “e”. A minute later it restarts again with the new firmware update successfully applied.

I really like these Webcaster X2 devices, but updates are essential. Unfortunately there seems to be some units sold in the last 12 months with a hardware bug that prevents them from being updated. :neutral_face:


I am having same problem as above , 2.14 Update goes Android System Recovery.
here is the serial number and the Mac address of the unit.
Thanks for your help. S/N wcx217061845


Can you please try performing a reset of the unit under Settings -> Backup and reset and afterwards attempt to perform the update again?

Hi Adam,

Since it’s update time, I was able to confirm my suspicion that updates fail when our Webcaster X2 is set to use a static IP address.

After getting the “Android System Recovery” menu several times, here is what I did:

  1. Go to Settings / Ethernet,
  2. Change Ethernet IP Mode to “DHCP” and exit Settings,
  3. Unplug power cable on then power up again,
  4. Wait until “Update Available” appears and click it,
  5. When “Restart to Update” appears click it and then wait,
  6. Update is being applied when you see the spinning “e” logo.
  7. After firmware update has completed successfully, device will boot back into Epiphan UI. If desired, go back into Settings / Ethernet and set Ethernet IP Mode back to “Static” (all IP information will be saved from before).

If anyone goes through this procedure several times and they still get the Android System Recover menu, then consider seeing if there were any other changes made in Settings.

From our experience I can confirm two facts: (1) Doing a reset of the unit under Settings -> Backup & Reset did nothing to help the problem, and (2) Doing a factory reset of the unit in this manner didn’t seem to change the Ethernet IP Mode back to the factory default. So, since the only change we ever made in Settings was giving the device a static IP address, it was a simple matter of taking a vanilla device and changing only the Ethernet IP Mode to determine if that caused updates to succeed or fail.